Seite 1 von 1

Swap Partion - Verhalten konfigurieren

Verfasst: Mon 4. Jun 2018, 16:56
von h3rb3rn
Fassung vom 04.08.2020

Quelle: https://wiki.ubuntuusers.de/Swap/

Bei der Konfiguration eines Proxmox Servers ist es aufgefallen das bei der Funktion Memory Sharing zwischen den VMs die Swap Partition trotz ausreichen freiem RAM unnötig stark ausgelastet war.

Dies lag an der Standard Einstellung bei der ab 60% Belegung des Arbeitsspeicher die Swap Partition (Auslagerungsspeicher) verwendet wird.

Quelle: https://forum.proxmox.com/threads/swap- ... ram.38613/


Für Debian Buster zusätzlich

Verzeichnis und Systemd Datei anlegen

Code: Alles auswählen

sudo mkdir -p /etc/systemd/system.conf.d;
sudo echo "[Manager]" > /etc/systemd/system.conf.d/disable-memory-accounting.conf;
sudo echo "DefaultMemoryAccounting=no" >> /etc/systemd/system.conf.d/disable-memory-accounting.conf;
chmod 644 /etc/systemd/system.conf.d/disable-memory-accounting.conf
Für Ubuntu und bis Debian 9 (stretch)

Dieser Wert kann mit nachfolgenden Befehlen angepasst werden.

Code: Alles auswählen

sudo sysctl vm.swappiness=10



Swap Partition/Datei Nutzung

ausschalten mit

Code: Alles auswählen

sudo swapoff -a

einschalten mit

Code: Alles auswählen

sudo swapon -a


Swap Konfiguration neu laden

Code: Alles auswählen

sudo sysctl --system


Einstellung dauerhaft speichern

Code: Alles auswählen

sudo echo "vm.swappiness=10" >> /etc/sysctl.conf


Ab Debian Buster

Das setzen von vm.swappiness=0 in der /etc/sysctl.conf wird bei Debian Buster ignoriert.

Datei /etc/tmpfiles.d/swappiness.conf anlegen und Inhalt einpflegen

Code: Alles auswählen

w   /sys/fs/cgroup/memory/system.slice/memory.swappiness -    -    -    -   0
System neustarten um Änderung zu übernehmen

Code: Alles auswählen

cat /sys/fs/cgroup/memory/system.slice/memory.swappiness
0